Please download this. https://www.google.com/chrome/browser/canary.html 

This basically lets you load a separate Chrome with the latest bug fixes.

If this works for you, then we can definitively say that the Chrome you currently use will need to be reset or perhaps your browser profile got corrupted. It happens with Mac’s Chrome from time to time with the google account logged in.

---

Here's what to do with your original Chrome browser:

  • Just to make sure we eliminate malware from the scenario, please download something like Malwarebytes to scan.
  • Clear your cache completely. 
  • Try resetting the Chrome browser to see if that helps.
  • Also, creating a new user profile on your Chrome can be helpful.
  • (Backup your bookmarks by exporting them as an html file to your desktop or documents folder or other) then, try resetting the Chrome browser to see if that helps

If the issue still persists, then there's a possibility of your browser profile being corrupted. 

  • Quit Google Chrome completely.
  • In the Mac menu bar at the top of the screen, click Go.
  • Select Go to Folder.
  • Enter ~/Library/Application Support/Google/Chrome/ in the text field, then press Go.
  • Locate the folder called "Default" in the directory window that opens and rename it as "Backup default."
  • Try opening Google Chrome again. A new "Default" folder is automatically created as you start using the browser.
  • Once the new profile is created, try signing in Chrome and check if the issue is fixed.

Did this answer your question?